<!DOCTYPE html><html lang="en" ng-controller="AppCtrl"><head><style type="text/css">[uib-typeahead-popup].dropdown-menu{display:block;}</style><style type="text/css">.uib-time input{width:50px;}</style><style type="text/css">[uib-tooltip-popup].tooltip.top-left > .tooltip-arrow,[uib-tooltip-popup].tooltip.top-right > .tooltip-arrow,[uib-tooltip-popup].tooltip.bottom-left > .tooltip-arrow,[uib-tooltip-popup].tooltip.bottom-right > .tooltip-arrow,[uib-tooltip-popup].tooltip.left-top > .tooltip-arrow,[uib-tooltip-popup].tooltip.left-bottom > .tooltip-arrow,[uib-tooltip-popup].tooltip.right-top > .tooltip-arrow,[uib-tooltip-popup].tooltip.right-bottom > .tooltip-arrow,[uib-tooltip-html-popup].tooltip.top-left > .tooltip-arrow,[uib-tooltip-html-popup].tooltip.top-right > .tooltip-arrow,[uib-tooltip-html-popup].tooltip.bottom-left > .tooltip-arrow,[uib-tooltip-html-popup].tooltip.bottom-right > .tooltip-arrow,[uib-tooltip-html-popup].tooltip.left-top > .tooltip-arrow,[uib-tooltip-html-popup].tooltip.left-bottom > .tooltip-arrow,[uib-tooltip-html-popup].tooltip.right-top > .tooltip-arrow,[uib-tooltip-html-popup].tooltip.right-bottom > .tooltip-arrow,[uib-tooltip-template-popup].tooltip.top-left > .tooltip-arrow,[uib-tooltip-template-popup].tooltip.top-right > .tooltip-arrow,[uib-tooltip-template-popup].tooltip.bottom-left > .tooltip-arrow,[uib-tooltip-template-popup].tooltip.bottom-right > .tooltip-arrow,[uib-tooltip-template-popup].tooltip.left-top > .tooltip-arrow,[uib-tooltip-template-popup].tooltip.left-bottom > .tooltip-arrow,[uib-tooltip-template-popup].tooltip.right-top > .tooltip-arrow,[uib-tooltip-template-popup].tooltip.right-bottom > .tooltip-arrow,[uib-popover-popup].popover.top-left > .arrow,[uib-popover-popup].popover.top-right > .arrow,[uib-popover-popup].popover.bottom-left > .arrow,[uib-popover-popup].popover.bottom-right > .arrow,[uib-popover-popup].popover.left-top > .arrow,[uib-popover-popup].popover.left-bottom > .arrow,[uib-popover-popup].popover.right-top > .arrow,[uib-popover-popup].popover.right-bottom > .arrow,[uib-popover-html-popup].popover.top-left > .arrow,[uib-popover-html-popup].popover.top-right > .arrow,[uib-popover-html-popup].popover.bottom-left > .arrow,[uib-popover-html-popup].popover.bottom-right > .arrow,[uib-popover-html-popup].popover.left-top > .arrow,[uib-popover-html-popup].popover.left-bottom > .arrow,[uib-popover-html-popup].popover.right-top > .arrow,[uib-popover-html-popup].popover.right-bottom > .arrow,[uib-popover-template-popup].popover.top-left > .arrow,[uib-popover-template-popup].popover.top-right > .arrow,[uib-popover-template-popup].popover.bottom-left > .arrow,[uib-popover-template-popup].popover.bottom-right > .arrow,[uib-popover-template-popup].popover.left-top > .arrow,[uib-popover-template-popup].popover.left-bottom > .arrow,[uib-popover-template-popup].popover.right-top > .arrow,[uib-popover-template-popup].popover.right-bottom > .arrow{top:auto;bottom:auto;left:auto;right:auto;margin:0;}[uib-popover-popup].popover,[uib-popover-html-popup].popover,[uib-popover-template-popup].popover{display:block !important;}</style><style type="text/css">.uib-datepicker-popup.dropdown-menu{display:block;float:none;margin:0;}.uib-button-bar{padding:10px 9px 2px;}</style><style type="text/css">.uib-position-measure{display:block !important;visibility:hidden !important;position:absolute !important;top:-9999px !important;left:-9999px !important;}.uib-position-scrollbar-measure{position:absolute !important;top:-9999px !important;width:50px !important;height:50px !important;overflow:scroll !important;}.uib-position-body-scrollbar-measure{overflow:scroll !important;}</style><style type="text/css">.uib-datepicker .uib-title{width:100%;}.uib-day button,.uib-month button,.uib-year button{min-width:100%;}.uib-left,.uib-right{width:100%}</style><style type="text/css">.ng-animate.item:not(.left):not(.right){-webkit-transition:0s ease-in-out left;transition:0s ease-in-out left}</style><style type="text/css">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</style><style type="text/css">@charset "UTF-8";[ng\:cloak],[ng-cloak],[data-ng-cloak],[x-ng-cloak],.ng-cloak,.x-ng-cloak,.ng-hide:not(.ng-hide-animate){display:none !important;}ng\:form{display:block;}.ng-animate-shim{visibility:hidden;}.ng-anchor{position:absolute;}</style> <meta charset="utf-8"> <base href="/"> <title data-cg-meta="">Developer Community Forum - CodinGame</title> <meta name="description" data-cg-meta="" content="Discuss and share with others about your favorite tech and programming topics."> <meta name="robots" data-cg-meta="" content="index, follow"> <meta name="viewport" content="width=device-width,user-scalable=no"> <meta property="og:site_name" content="CodinGame"> <meta property="og:type" content="website"> <meta property="og:title" data-cg-meta="" content="Developer Community Forum - CodinGame"> <meta property="og:description" data-cg-meta="" content="Discuss and share with others about your favorite tech and programming topics."> <meta property="og:image" data-cg-meta="" content="https://files.codingame.com/codingame/codingame_share_pics.jpg"> <meta name="twitter:card" content="summary_large_image"> <meta name="twitter:title" data-cg-meta="" content="Developer Community Forum - CodinGame"> <meta name="twitter:description" data-cg-meta="" content="Discuss and share with others about your favorite tech and programming topics."> <meta name="twitter:image" data-cg-meta="" content="https://files.codingame.com/codingame/codingame_share_pics.jpg"> <link rel="alternate" type="application/atom+xml" title="CodinGame - Blog - Atom" href="https://www.codingame.com/blog/feed/atom/"> <link rel="alternate" type="application/rss+xml" title="CodinGame - Blog - RSS" href="https://www.codingame.com/blog/feed/"> <link rel="icon" type="image/png" sizes="16x16" href="https://static.codingame.com/assets/favicon_16_16.597edc73.png"> <link rel="icon" type="image/png" sizes="32x32" href="https://static.codingame.com/assets/favicon_32_32.3e3c075c.png"> <link rel="shortcut icon" type="image/x-icon" sizes="32x32" href="https://static.codingame.com/assets/favicon_32_32.563f9135.ico"> <link rel="shortcut icon" type="image/x-icon" sizes="16x16" href="https://static.codingame.com/assets/favicon_16_16.1e3eb433.ico"> <link rel="apple-touch-icon" href="https://static.codingame.com/assets/apple-touch-icon-192x192.cc431ee4.png"> <link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://static.codingame.com/assets/apple-touch-icon-152x152-precomposed.2271ef33.png"> <link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://static.codingame.com/assets/apple-touch-icon-120x120-precomposed.b3656aad.png"> <link href="//fonts.googleapis.com/css?family=Lato:300,400,700,900,300italic,400italic,700italic,900italic" rel="stylesheet" type="text/css"> <link href="//fonts.googleapis.com/css?family=Inconsolata:400,700" rel="stylesheet" type="text/css"> <link href="//fonts.googleapis.com/css?family=Open+Sans:300,300i,400,600,700,800,900" rel="stylesheet" type="text/css"> <!----> <link rel="canonical" ng-href="https://www.codingame.com/forum/t/hitori-solver-some-thoughts/51095/3" href="https://www.codingame.com/forum/t/hitori-solver-some-thoughts/51095/3">   <style>.async-hide{opacity:0!important}</style>      <link href="https://static.codingame.com/app-41fae711.css" rel="stylesheet"><style type="text/css">.MathJax_Hover_Frame {border-radius: .25em; -webkit-border-radius: .25em; -moz-border-radius: .25em; -khtml-border-radius: .25em; box-shadow: 0px 0px 15px #83A; -webkit-box-shadow: 0px 0px 15px #83A; -moz-box-shadow: 0px 0px 15px #83A; -khtml-box-shadow: 0px 0px 15px #83A; border: 1px solid #A6D ! important; display: inline-block; position: absolute}
.MathJax_Menu_Button .MathJax_Hover_Arrow {position: absolute; cursor: pointer; display: inline-block; border: 2px solid #AAA; border-radius: 4px; -webkit-border-radius: 4px; -moz-border-radius: 4px; -khtml-border-radius: 4px; font-family: 'Courier New',Courier; font-size: 9px; color: #F0F0F0}
.MathJax_Menu_Button .MathJax_Hover_Arrow span {display: block; background-color: #AAA; border: 1px solid; border-radius: 3px; line-height: 0; padding: 4px}
.MathJax_Hover_Arrow:hover {color: white!important; border: 2px solid #CCC!important}
.MathJax_Hover_Arrow:hover span {background-color: #CCC!important}
</style><style type="text/css">#MathJax_About {position: fixed; left: 50%; width: auto; text-align: center; border: 3px outset; padding: 1em 2em; background-color: #DDDDDD; color: black; cursor: default; font-family: message-box; font-size: 120%; font-style: normal; text-indent: 0; text-transform: none; line-height: normal; letter-spacing: normal; word-spacing: normal; word-wrap: normal; white-space: nowrap; float: none; z-index: 201; border-radius: 15px; -webkit-border-radius: 15px; -moz-border-radius: 15px; -khtml-border-radius: 15px; box-shadow: 0px 10px 20px #808080; -webkit-box-shadow: 0px 10px 20px #808080; -moz-box-shadow: 0px 10px 20px #808080; -khtml-box-shadow: 0px 10px 20px #808080; filter: progid:DXImageTransform.Microsoft.dropshadow(OffX=2, OffY=2, Color='gray', Positive='true')}
#MathJax_About.MathJax_MousePost {outline: none}
.MathJax_Menu {position: absolute; background-color: white; color: black; width: auto; padding: 5px 0px; border: 1px solid #CCCCCC; margin: 0; cursor: default; font: menu; text-align: left; text-indent: 0; text-transform: none; line-height: normal; letter-spacing: normal; word-spacing: normal; word-wrap: normal; white-space: nowrap; float: none; z-index: 201; border-radius: 5px; -webkit-border-radius: 5px; -moz-border-radius: 5px; -khtml-border-radius: 5px; box-shadow: 0px 10px 20px #808080; -webkit-box-shadow: 0px 10px 20px #808080; -moz-box-shadow: 0px 10px 20px #808080; -khtml-box-shadow: 0px 10px 20px #808080; filter: progid:DXImageTransform.Microsoft.dropshadow(OffX=2, OffY=2, Color='gray', Positive='true')}
.MathJax_MenuItem {padding: 1px 2em; background: transparent}
.MathJax_MenuArrow {position: absolute; right: .5em; padding-top: .25em; color: #666666; font-size: .75em}
.MathJax_MenuActive .MathJax_MenuArrow {color: white}
.MathJax_MenuArrow.RTL {left: .5em; right: auto}
.MathJax_MenuCheck {position: absolute; left: .7em}
.MathJax_MenuCheck.RTL {right: .7em; left: auto}
.MathJax_MenuRadioCheck {position: absolute; left: .7em}
.MathJax_MenuRadioCheck.RTL {right: .7em; left: auto}
.MathJax_MenuLabel {padding: 1px 2em 3px 1.33em; font-style: italic}
.MathJax_MenuRule {border-top: 1px solid #DDDDDD; margin: 4px 3px}
.MathJax_MenuDisabled {color: GrayText}
.MathJax_MenuActive {background-color: #606872; color: white}
.MathJax_MenuDisabled:focus, .MathJax_MenuLabel:focus {background-color: #E8E8E8}
.MathJax_ContextMenu:focus {outline: none}
.MathJax_ContextMenu .MathJax_MenuItem:focus {outline: none}
#MathJax_AboutClose {top: .2em; right: .2em}
.MathJax_Menu .MathJax_MenuClose {top: -10px; left: -10px}
.MathJax_MenuClose {position: absolute; cursor: pointer; display: inline-block; border: 2px solid #AAA; border-radius: 18px; -webkit-border-radius: 18px; -moz-border-radius: 18px; -khtml-border-radius: 18px; font-family: 'Courier New',Courier; font-size: 24px; color: #F0F0F0}
.MathJax_MenuClose span {display: block; background-color: #AAA; border: 1.5px solid; border-radius: 18px; -webkit-border-radius: 18px; -moz-border-radius: 18px; -khtml-border-radius: 18px; line-height: 0; padding: 8px 0 6px}
.MathJax_MenuClose:hover {color: white!important; border: 2px solid #CCC!important}
.MathJax_MenuClose:hover span {background-color: #CCC!important}
.MathJax_MenuClose:hover:focus {outline: none}
</style><style type="text/css">.MathJax_Preview .MJXf-math {color: inherit!important}
</style><style type="text/css">.MJX_Assistive_MathML {position: absolute!important; top: 0; left: 0; clip: rect(1px, 1px, 1px, 1px); padding: 1px 0 0 0!important; border: 0!important; height: 1px!important; width: 1px!important; overflow: hidden!important; display: block!important; -webkit-touch-callout: none; -webkit-user-select: none; -khtml-user-select: none; -moz-user-select: none; -ms-user-select: none; user-select: none}
.MJX_Assistive_MathML.MJX_Assistive_MathML_Block {width: 100%!important}
</style><style type="text/css">#MathJax_Zoom {position: absolute; background-color: #F0F0F0; overflow: auto; display: block; z-index: 301; padding: .5em; border: 1px solid black; margin: 0; font-weight: normal; font-style: normal; text-align: left; text-indent: 0; text-transform: none; line-height: normal; letter-spacing: normal; word-spacing: normal; word-wrap: normal; white-space: nowrap; float: none; -webkit-box-sizing: content-box; -moz-box-sizing: content-box; box-sizing: content-box; box-shadow: 5px 5px 15px #AAAAAA; -webkit-box-shadow: 5px 5px 15px #AAAAAA; -moz-box-shadow: 5px 5px 15px #AAAAAA; -khtml-box-shadow: 5px 5px 15px #AAAAAA; filter: progid:DXImageTransform.Microsoft.dropshadow(OffX=2, OffY=2, Color='gray', Positive='true')}
#MathJax_ZoomOverlay {position: absolute; left: 0; top: 0; z-index: 300; display: inline-block; width: 100%; height: 100%; border: 0; padding: 0; margin: 0; background-color: white; opacity: 0; filter: alpha(opacity=0)}
#MathJax_ZoomFrame {position: relative; display: inline-block; height: 0; width: 0}
#MathJax_ZoomEventTrap {position: absolute; left: 0; top: 0; z-index: 302; display: inline-block; border: 0; padding: 0; margin: 0; background-color: white; opacity: 0; filter: alpha(opacity=0)}
</style><style type="text/css">.MathJax_Preview {color: #888}
#MathJax_Message {position: fixed; left: 1px; bottom: 2px; background-color: #E6E6E6; border: 1px solid #959595; margin: 0px; padding: 2px 8px; z-index: 102; color: black; font-size: 80%; width: auto; white-space: nowrap}
#MathJax_MSIE_Frame {position: absolute; top: 0; left: 0; width: 0px; z-index: 101; border: 0px; margin: 0px; padding: 0px}
.MathJax_Error {color: #CC0000; font-style: italic}
</style><style>.markdown-hover {
	line-height: normal !important;
}

.markdown-hover ul, .markdown-hover ol {
	list-style-position: inside;
}
/*# sourceMappingURL=data:application/json;base64,eyJ2ZXJzaW9uIjozLCJzb3VyY2VzIjpbIndlYnBhY2s6Ly9zcmMvaGFja3MuY3NzIl0sIm5hbWVzIjpbXSwibWFwcGluZ3MiOiJBQUFBO0NBQ0MsOEJBQThCO0FBQy9COztBQUVBO0NBQ0MsMkJBQTJCO0FBQzVCIiwic291cmNlc0NvbnRlbnQiOlsiLm1hcmtkb3duLWhvdmVyIHtcblx0bGluZS1oZWlnaHQ6IG5vcm1hbCAhaW1wb3J0YW50O1xufVxuXG4ubWFya2Rvd24taG92ZXIgdWwsIC5tYXJrZG93bi1ob3ZlciBvbCB7XG5cdGxpc3Qtc3R5bGUtcG9zaXRpb246IGluc2lkZTtcbn0iXSwic291cmNlUm9vdCI6IiJ9 */</style><link rel="prefetch" as="script" href="https://static.codingame.com/55.0707d03d.js"><link rel="prefetch" as="script" href="https://static.codingame.com/56.12e19211.js"><link rel="prefetch" as="script" href="https://static.codingame.com/57.5225c60b.js"><link rel="prefetch" as="script" href="https://static.codingame.com/58.a2bc37e5.js"><link rel="prefetch" as="script" href="https://static.codingame.com/59.8f2e6193.js"><link rel="prefetch" as="script" href="https://static.codingame.com/60.ad6c61ff.js"><link rel="prefetch" as="script" href="https://static.codingame.com/61.68b0ec63.js"><link rel="prefetch" as="script" href="https://static.codingame.com/62.a0adfe01.js"><link rel="prefetch" as="script" href="https://static.codingame.com/63.3d4bbce7.js"><link rel="prefetch" as="script" href="https://static.codingame.com/64.fb240901.js"><link rel="prefetch" as="script" href="https://static.codingame.com/65.009980c1.js"><link rel="prefetch" as="script" href="https://static.codingame.com/11.e1dde3f3.js"><link rel="prefetch" as="script" href="https://static.codingame.com/66.237f3d2e.js"><link rel="prefetch" as="script" href="https://static.codingame.com/67.d7c7ba06.js"><link rel="prefetch" as="script" href="https://static.codingame.com/68.bd32f399.js"><link rel="prefetch" as="script" href="https://static.codingame.com/69.a423f66d.js"><link rel="prefetch" as="script" href="https://static.codingame.com/70.3c3cb8fc.js"><link rel="prefetch" as="script" href="https://static.codingame.com/71.c7aefdab.js"><link rel="prefetch" as="script" href="https://static.codingame.com/72.bc9f758d.js"><link rel="prefetch" as="script" href="https://static.codingame.com/73.64ca6b06.js"><link rel="prefetch" as="script" href="https://static.codingame.com/74.f920f0a6.js"><link rel="prefetch" as="script" href="https://static.codingame.com/75.6058fa38.js"><link rel="prefetch" as="script" href="https://static.codingame.com/76.901bb104.js"><link rel="prefetch" as="script" href="https://static.codingame.com/77.c28153d9.js"><link rel="prefetch" as="script" href="https://static.codingame.com/78.5feaf6ac.js"><link rel="prefetch" as="script" href="https://static.codingame.com/79.9df4fb05.js"><link rel="prefetch" as="script" href="https://static.codingame.com/80.cc85cbb2.js"><link rel="prefetch" as="script" href="https://static.codingame.com/81.a0e137c7.js"><link rel="prefetch" as="script" href="https://static.codingame.com/82.4186684f.js"><link rel="prefetch" as="script" href="https://static.codingame.com/83.9c58a92a.js"><link rel="prefetch" as="script" href="https://static.codingame.com/84.cca17e38.js"><link rel="prefetch" as="script" href="https://static.codingame.com/85.63564f45.js"><link rel="prefetch" as="script" href="https://static.codingame.com/86.7e52663e.js"><link rel="prefetch" as="script" href="https://static.codingame.com/87.4a4bed69.js"><link rel="prefetch" as="script" href="https://static.codingame.com/88.06bc284c.js"><link rel="prefetch" as="script" href="https://static.codingame.com/89.93c6164d.js"><link rel="prefetch" as="script" href="https://static.codingame.com/90.2c6d00dc.js"><link rel="prefetch" as="script" href="https://static.codingame.com/91.0ca9ae59.js"><link rel="prefetch" as="script" href="https://static.codingame.com/92.ef7bea9e.js"><link rel="prefetch" as="script" href="https://static.codingame.com/93.798b18d7.js"><link rel="prefetch" as="script" href="https://static.codingame.com/94.7b79c7da.js"><link rel="prefetch" as="script" href="https://static.codingame.com/95.f3c11ec9.js"><link rel="prefetch" as="script" href="https://static.codingame.com/96.64586ec6.js"><link rel="prefetch" as="script" href="https://static.codingame.com/97.684d2e34.js"><link rel="prefetch" as="script" href="https://static.codingame.com/98.f12c6dc7.js"><link rel="prefetch" as="script" href="https://static.codingame.com/99.a11adf48.js"><link rel="prefetch" as="script" href="https://static.codingame.com/100.6e579dc6.js"><link rel="prefetch" as="script" href="https://static.codingame.com/101.dfba14ee.js"><link rel="prefetch" as="script" href="https://static.codingame.com/102.e1801b96.js"><link rel="prefetch" as="script" href="https://static.codingame.com/103.3ff07115.js"><link rel="prefetch" as="script" href="https://static.codingame.com/104.6cb81865.js"><link rel="prefetch" as="script" href="https://static.codingame.com/105.9bc7e1f3.js"><link rel="prefetch" as="script" href="https://static.codingame.com/106.d96d0556.js"><link rel="prefetch" as="script" href="https://static.codingame.com/107.65eec7ec.js"><link rel="prefetch" as="script" href="https://static.codingame.com/108.660c7d4b.js"><link rel="prefetch" as="script" href="https://static.codingame.com/109.08abbc69.js"><link rel="prefetch" as="script" href="https://static.codingame.com/110.333b4753.js"><link rel="prefetch" as="script" href="https://static.codingame.com/111.24f740f6.js"><link rel="prefetch" as="script" href="https://static.codingame.com/112.8865e52b.js"><link rel="prefetch" as="script" href="https://static.codingame.com/113.b3228702.js"><link rel="prefetch" as="script" href="https://static.codingame.com/114.64de26d6.js"><link rel="prefetch" as="script" href="https://static.codingame.com/115.322c1e79.js"><link rel="prefetch" as="script" href="https://static.codingame.com/116.04180eb6.js"><link rel="prefetch" as="script" href="https://static.codingame.com/117.dcbfa13e.js"><link rel="prefetch" as="script" href="https://static.codingame.com/118.0d2ca78c.js"><link rel="prefetch" as="script" href="https://static.codingame.com/119.4f9113d9.js"><link rel="prefetch" as="script" href="https://static.codingame.com/120.89c152c0.js"><link rel="prefetch" as="script" href="https://static.codingame.com/121.e70e2adf.js"><link rel="prefetch" as="script" href="https://static.codingame.com/122.f656d180.js"><link rel="prefetch" as="script" href="https://static.codingame.com/123.ae7d9e54.js"><style data-jss="" data-meta="Themed">
.onContainer-0-2-1 {
  height: 100%;
  display: flex;
  position: relative;
  margin-right: 14px;
}
.offContainer-0-2-2 {
  height: 100%;
  display: flex;
  position: relative;
}
.onIconIde-0-2-3 {
  color: #f2bb13;
  width: 36px;
  height: 26px;
  transition: color .2s;
}
.onIconIde-0-2-3:hover {
  color: rgba(242, 187, 19, 0.7);
}
.theme-white .onIconIde-0-2-3 {
  color: #b3b9ad;
}
.theme-white .onIconIde-0-2-3:hover {
  color: #252e38;
}
.offIconIde-0-2-4 {
  color: #ffffff;
  width: 36px;
  height: 26px;
  transition: color .2s;
}
.offIconIde-0-2-4:hover {
  color: rgba(255, 255, 255, 0.7);
}
.theme-white .offIconIde-0-2-4 {
  color: #b3b9ad;
}
.theme-white .offIconIde-0-2-4:hover {
  color: #252e38;
}
.onIcon-0-2-5 {
  color: #f2bb13;
  width: 46px;
  height: 38px;
  transition: color .2s;
}
.onIcon-0-2-5:hover {
  color: rgba(242, 187, 19, 0.7);
}
.offIcon-0-2-6 {
  color: #ffffff;
  width: 46px;
  height: 38px;
  transition: color .2s;
}
.offIcon-0-2-6:hover {
  color: rgba(255, 255, 255, 0.7);
}
.badgeContainerIde-0-2-7 {
  right: -16px;
  padding: 2px;
  position: absolute;
  min-width: 22px;
  min-height: 22px;
  border-radius: 50%;
  background-color: #131c25;
}
.theme-white .badgeContainerIde-0-2-7 {
  background-color: #eef1f2;
}
.badgeContainer-0-2-8 {
  top: 8px;
  right: -16px;
  padding: 2px;
  position: absolute;
  min-width: 22px;
  min-height: 22px;
  border-radius: 50%;
  background-color: #252e38;
}
.badge-0-2-9 {
  min-width: 20px;
  min-height: 20px;
  border-radius: 50%;
  background-color: #fe3e45;
}
.badgeText-0-2-10 {
  color: #ffffff;
  font-size: 14px;
  text-align: center;
  font-weight: 700;
}
</style><link rel="stylesheet" type="text/css" href="https://static.codingame.com/forum-de00c707.css"><style type="text/css">.MJXp-script {font-size: .8em}
.MJXp-right {-webkit-transform-origin: right; -moz-transform-origin: right; -ms-transform-origin: right; -o-transform-origin: right; transform-origin: right}
.MJXp-bold {font-weight: bold}
.MJXp-italic {font-style: italic}
.MJXp-scr {font-family: MathJax_Script,'Times New Roman',Times,STIXGeneral,serif}
.MJXp-frak {font-family: MathJax_Fraktur,'Times New Roman',Times,STIXGeneral,serif}
.MJXp-sf {font-family: MathJax_SansSerif,'Times New Roman',Times,STIXGeneral,serif}
.MJXp-cal {font-family: MathJax_Caligraphic,'Times New Roman',Times,STIXGeneral,serif}
.MJXp-mono {font-family: MathJax_Typewriter,'Times New Roman',Times,STIXGeneral,serif}
.MJXp-largeop {font-size: 150%}
.MJXp-largeop.MJXp-int {vertical-align: -.2em}
.MJXp-math {display: inline-block; line-height: 1.2; text-indent: 0; font-family: 'Times New Roman',Times,STIXGeneral,serif; white-space: nowrap; border-collapse: collapse}
.MJXp-display {display: block; text-align: center; margin: 1em 0}
.MJXp-math span {display: inline-block}
.MJXp-box {display: block!important; text-align: center}
.MJXp-box:after {content: " "}
.MJXp-rule {display: block!important; margin-top: .1em}
.MJXp-char {display: block!important}
.MJXp-mo {margin: 0 .15em}
.MJXp-mfrac {margin: 0 .125em; vertical-align: .25em}
.MJXp-denom {display: inline-table!important; width: 100%}
.MJXp-denom > * {display: table-row!important}
.MJXp-surd {vertical-align: top}
.MJXp-surd > * {display: block!important}
.MJXp-script-box > *  {display: table!important; height: 50%}
.MJXp-script-box > * > * {display: table-cell!important; vertical-align: top}
.MJXp-script-box > *:last-child > * {vertical-align: bottom}
.MJXp-script-box > * > * > * {display: block!important}
.MJXp-mphantom {visibility: hidden}
.MJXp-munderover {display: inline-table!important}
.MJXp-over {display: inline-block!important; text-align: center}
.MJXp-over > * {display: block!important}
.MJXp-munderover > * {display: table-row!important}
.MJXp-mtable {vertical-align: .25em; margin: 0 .125em}
.MJXp-mtable > * {display: inline-table!important; vertical-align: middle}
.MJXp-mtr {display: table-row!important}
.MJXp-mtd {display: table-cell!important; text-align: center; padding: .5em 0 0 .5em}
.MJXp-mtr > .MJXp-mtd:first-child {padding-left: 0}
.MJXp-mtr:first-child > .MJXp-mtd {padding-top: 0}
.MJXp-mlabeledtr {display: table-row!important}
.MJXp-mlabeledtr > .MJXp-mtd:first-child {padding-left: 0}
.MJXp-mlabeledtr:first-child > .MJXp-mtd {padding-top: 0}
.MJXp-merror {background-color: #FFFF88; color: #CC0000; border: 1px solid #CC0000; padding: 1px 3px; font-style: normal; font-size: 90%}
.MJXp-scale0 {-webkit-transform: scaleX(.0); -moz-transform: scaleX(.0); -ms-transform: scaleX(.0); -o-transform: scaleX(.0); transform: scaleX(.0)}
.MJXp-scale1 {-webkit-transform: scaleX(.1); -moz-transform: scaleX(.1); -ms-transform: scaleX(.1); -o-transform: scaleX(.1); transform: scaleX(.1)}
.MJXp-scale2 {-webkit-transform: scaleX(.2); -moz-transform: scaleX(.2); -ms-transform: scaleX(.2); -o-transform: scaleX(.2); transform: scaleX(.2)}
.MJXp-scale3 {-webkit-transform: scaleX(.3); -moz-transform: scaleX(.3); -ms-transform: scaleX(.3); -o-transform: scaleX(.3); transform: scaleX(.3)}
.MJXp-scale4 {-webkit-transform: scaleX(.4); -moz-transform: scaleX(.4); -ms-transform: scaleX(.4); -o-transform: scaleX(.4); transform: scaleX(.4)}
.MJXp-scale5 {-webkit-transform: scaleX(.5); -moz-transform: scaleX(.5); -ms-transform: scaleX(.5); -o-transform: scaleX(.5); transform: scaleX(.5)}
.MJXp-scale6 {-webkit-transform: scaleX(.6); -moz-transform: scaleX(.6); -ms-transform: scaleX(.6); -o-transform: scaleX(.6); transform: scaleX(.6)}
.MJXp-scale7 {-webkit-transform: scaleX(.7); -moz-transform: scaleX(.7); -ms-transform: scaleX(.7); -o-transform: scaleX(.7); transform: scaleX(.7)}
.MJXp-scale8 {-webkit-transform: scaleX(.8); -moz-transform: scaleX(.8); -ms-transform: scaleX(.8); -o-transform: scaleX(.8); transform: scaleX(.8)}
.MJXp-scale9 {-webkit-transform: scaleX(.9); -moz-transform: scaleX(.9); -ms-transform: scaleX(.9); -o-transform: scaleX(.9); transform: scaleX(.9)}
.MathJax_PHTML .noError {vertical-align: ; font-size: 90%; text-align: left; color: black; padding: 1px 3px; border: 1px solid}
</style><style type="text/css" data-fbcssmodules="css:fb.css.basecss:fb.css.dialog css:fb.css.iframewidget">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</style></head> <body class="hide_chat variant-1A-active chat-open menuVisible chat-hidden" ng-class="{
      'mobile': pageLayoutService.mobile,
      'menuVisible': pageLayoutService.menuVisible,
      'fullscreen': pageLayoutService.fullscreen,
      'scrollable': pageLayoutService.scrollable,
      'pageLoaded': crawlerService.isPageLoaded(),
      'chat-open': chatService.open,
      'chat-hidden': chatService.hidden
    }" ng-mouseleave="careerService.showOptinPopupPlaygrounds()"><div id="fb-root" class=" fb_reset"><div style="position: absolute; top: -10000px; width: 0px; height: 0px;"><div></div></div></div><div id="MathJax_Message" style="display: none;"></div>   <help-popup><div class="help-popup ng-hide" ng-show="helpOn" help-popup-window-resize="" ng-class="{ 'mobile': mobile === true }"> <div class="header" ng-mousedown="onMouseDown($event)" help-popup-drag-and-drop=""> <div class="title" ng-bind="title"></div> <div class="back-button ng-hide" ng-click="previousArticle()" ng-show="hasHistory"><img src="data:image/png;base64,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" alt="Back"></div> <div class="close-button" ng-click="closePopup()"><img src="data:image/png;base64,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" alt="Close"></div> </div> <div class="content_wrapper" ng-click="$event.stopPropagation()"> <div class="content" ng-bind-html="content" help-link-manager=""></div> </div> </div></help-popup> <nav id="navigation" ng-show="pageLayoutService.menuVisible" ng-class="{impersonated: sessionService.session.impersonated}" class=""> <!----> <!----><div class="navigation_nav-wrapper" ng-if="!showStartHeader()"> <navigation-hiring-work><div class="navigation-hiring-work-container"> <!----><div ng-if="$ctrl.navigationService.displayWorkBanner" class="navigation-hiring-work"> <button ng-click="$ctrl.navigationService.onHideWorkBanner()"> <svg class="cross" cg-svg="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMiIgaGVpZ2h0PSIxMiIgdmlld0JveD0iMCAwIDEyIDEyIj48ZGVmcz48c3R5bGU+IC5fX2YzTDRCRnhfX2Nscy0xIHsgZmlsbDogI2ZmZjsgZmlsbC1ydWxlOiBldmVub2RkOyB9IDwvc3R5bGU+PC9kZWZzPjxwYXRoIGlkPSJ4IiBjbGFzcz0iX19mM0w0QkZ4X19jbHMtMSAiIGQ9Ik0xNzcxLjQxLDExMGw0LjMsNC4yOTNhMSwxLDAsMCwxLTEuNDIsMS40MTRsLTQuMjktNC4yOTMtNC4yOSw0LjI5M2ExLDEsMCwwLDEtMS40Mi0xLjQxNGw0LjMtNC4yOTMtNC4zLTQuMjkzYTEsMSwwLDAsMSwxLjQyLTEuNDE0bDQuMjksNC4yOTMsNC4yOS00LjI5M2ExLDEsMCwwLDEsMS40MiwxLjQxNFoiIHRyYW5zZm9ybT0idHJhbnNsYXRlKC0xNzY0IC0xMDQpIj48L3BhdGg+PC9zdmc+" viewBox="0 0 12 12"><path id="x" class="__f3L4BFx__cls-1 " d="M1771.41,110l4.3,4.293a1,1,0,0,1-1.42,1.414l-4.29-4.293-4.29,4.293a1,1,0,0,1-1.42-1.414l4.3-4.293-4.3-4.293a1,1,0,0,1,1.42-1.414l4.29,4.293,4.29-4.293a1,1,0,0,1,1.42,1.414Z" transform="translate(-1764 -104)"></path></svg> </button> <a ng-click="$ctrl.trackClick('companies')" ng-href="/work/?cg_referrer=%24direct" target="_blank" rel="noopener" href="/work/?cg_referrer=%24direct"> <span translate="navigation.hiring.employers">Employers: discover CodinGame for tech hiring</span> <svg class="arrow" cg-svg="data:image/svg+xml;base64,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" viewBox="0 0 18 15"><path transform="translate(9.000000, 7.500000) scale(-1, 1) translate(-9.000000, -7.500000) " class="__2bbKbJP__cls-1 " id="Path" d="M16.3935191,6.2723471 C16.3221515,6.26073218 16.2499261,6.25537446 16.1776616,6.25631304 L3.87277031,6.25631304 L4.14108099,6.13116908 C4.40334687,6.00668996 4.64194057,5.83727633 4.84617647,5.63059327 L8.29677652,2.17036299 C8.75122773,1.73533132 8.82758707,1.03550288 8.47773023,0.512205616 C8.07054539,-0.0454280145 7.28967553,-0.166504789 6.73355486,0.241816464 C6.68862843,0.274823181 6.64592491,0.310802068 6.60579531,0.349518478 L0.366012216,6.6067161 C-0.121626832,7.09516859 -0.122055817,7.88752535 0.36503725,8.37652534 C0.365349239,8.3768382 0.365700227,8.37719017 0.366012216,8.37750303 L6.60579531,14.6347007 C7.09382434,15.122723 7.88397587,15.121628 8.37067895,14.6322369 C8.40897562,14.593716 8.44473738,14.5527314 8.47773023,14.5095567 C8.82758707,13.9862594 8.75122773,13.286431 8.29677652,12.8513993 L4.85241626,9.38491185 C4.66931762,9.20110667 4.45880294,9.04698407 4.22843795,8.92813642 L3.85405096,8.75919209 L16.108985,8.75919209 C16.7464958,8.78293033 17.3058143,8.33636196 17.4255792,7.70798288 C17.5359063,7.02575281 17.0738504,6.38302129 16.3935191,6.2723471 Z"></path></svg> </a> </div><!----> </div></navigation-hiring-work> <div class="navigation_nav-container"> <!----> <!----><div class="navigation-desktop" ng-if="!pageLayoutService.mobile"> <div class="left"> <a href="/home" class="navigation-logo" ng-click="navigationService.toggleMenu(null)"> <div class="navigation-logo_image"></div> </a> <div class="navigation-desktop_nav-tabs"> <!----><a class="navigation-desktop_nav-tab" ng-repeat="tab in tabs track by $index" ng-href="/home" ng-class="{'navigation-desktop_selected': navigationService.isSelected(tab), 'tab-additionnal-margin': tab.notificationCount > 0}" ng-attr-id="navigation-{{tab.id}}" ng-attr-target="{{tab.target}}" ng-click="navigationService.performCallBackItem(tab)" href="/home" id="navigation-home"> <!----> <!----><svg ng-if="tab.icon" cg-svg="data:image/svg+xml;base64,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" class="navigation-desktop_svg" viewBox="0 0 17 17"><path fill="currentColor" d="M16.5416412,7.39418028 C16.5412521,7.39379121 16.540863,7.3934021 16.5404739,7.39301299 L9.60581972,0.458618164 C9.31023408,0.162902832 8.91724395,0 8.49922179,0 C8.08119965,0 7.68820953,0.162773141 7.39249419,0.458488473 L0.461471574,7.3893814 C0.459136963,7.39171601 0.456802352,7.39418028 0.454467773,7.39651489 C-0.152526855,8.00701142 -0.151489258,8.99752808 0.457450875,9.60646821 C0.735656738,9.88480376 1.103096,10.0460205 1.49595644,10.0628815 C1.51190948,10.0644379 1.52799224,10.0652161 1.5442047,10.0652161 L1.82059478,10.0652161 L1.82059478,15.1685104 C1.82059478,16.1783523 2.64224243,17 3.65234375,17 L6.36540224,17 C6.64036562,17 6.86344911,16.7770462 6.86344911,16.5019531 L6.86344911,12.5009766 C6.86344911,12.0401535 7.23828125,11.6653213 7.6991043,11.6653213 L9.2993393,11.6653213 C9.76016235,11.6653213 10.1349945,12.0401535 10.1349945,12.5009766 L10.1349945,16.5019531 C10.1349945,16.7770462 10.3579483,17 10.6330414,17 L13.3460999,17 C14.3562012,17 15.1778488,16.1783523 15.1778488,15.1685104 L15.1778488,10.0652161 L15.4341354,10.0652161 C15.8520279,10.0652161 16.245018,9.90244292 16.540863,9.60672759 C17.1504517,8.99674989 17.150711,8.00454712 16.5416412,7.39418028 L16.5416412,7.39418028 Z" id="Path"></path></svg><!----> <!----> </a><!----><a class="navigation-desktop_nav-tab" ng-repeat="tab in tabs track by $index" ng-href="/training" ng-class="{'navigation-desktop_selected': navigationService.isSelected(tab), 'tab-additionnal-margin': tab.notificationCount > 0}" ng-attr-id="navigation-{{tab.id}}" ng-attr-target="{{tab.target}}" ng-click="navigationService.performCallBackItem(tab)" href="/training" id="navigation-practice"> <!----><span ng-if="tab.title" translate="navigation.tabs.practice">Practice</span><!----> <!----> <!----> </a><!----><a class="navigation-desktop_nav-tab tab-additionnal-margin" ng-repeat="tab in tabs track by $index" ng-href="/multiplayer" ng-class="{'navigation-desktop_selected': navigationService.isSelected(tab), 'tab-additionnal-margin': tab.notificationCount > 0}" ng-attr-id="navigation-{{tab.id}}" ng-attr-target="{{tab.target}}" ng-click="navigationService.performCallBackItem(tab)" href="/multiplayer" id="navigation-compete"> <!----><span ng-if="tab.title" translate="navigation.tabs.compete">Compete</span><!----> <!----> <!----><div class="cg-notification-bubble" ng-style="{width: radius,
    height: radius,
    'border-radius': radius,
}" ng-if="tab.notificationCount > 0" count="tab.notificationCount" radius="24" font-size="11" small-font-size="9" style="width: 24px; height: 24px; border-radius: 24px;"> <span class="cg-notification-bubble_count" ng-class="{
        'cg-notification-bubble_small-counter': count > 99
    }" ng-style="{'font-size': getFontSize()}" ng-bind="count" style="font-size: 11px;">1</span> </div><!----> </a><!----><a class="navigation-desktop_nav-tab" ng-repeat="tab in tabs track by $index" ng-href="/contributions" ng-class="{'navigation-desktop_selected': navigationService.isSelected(tab), 'tab-additionnal-margin': tab.notificationCount > 0}" ng-attr-id="navigation-{{tab.id}}" ng-attr-target="{{tab.target}}" ng-click="navigationService.performCallBackItem(tab)" href="/contributions" id="navigation-contribute"> <!----><span ng-if="tab.title" translate="navigation.tabs.contribute">Contribute</span><!----> <!----> <!----> </a><!----><a class="navigation-desktop_nav-tab" ng-repeat="tab in tabs track by $index" ng-href="/learn" ng-class="{'navigation-desktop_selected': navigationService.isSelected(tab), 'tab-additionnal-margin': tab.notificationCount > 0}" ng-attr-id="navigation-{{tab.id}}" ng-attr-target="{{tab.target}}" ng-click="navigationService.performCallBackItem(tab)" href="/learn" id="navigation-learn"> <!----><span ng-if="tab.title" translate="navigation.tabs.learn">Learn</span><!----> <!----> <!----> </a><!----> <navigation-optin origin="header" variant="link"><!----></navigation-optin> </div> </div> <cg-navigation-search class="navigation-search" theme="dark"><div class="cg-navigation-search"> <cg-selector class="cg-selector" theme="dark" get-suggestions="$ctrl.getSuggestions(searchValue)" select-suggestion="$ctrl.selectSuggestion(suggestion, searchValue, isOnClick)" get-url="$ctrl.getUrl(suggestion)"><div class="cg-selector theme-dark" ng-class="'theme-' + (theme || 'light')"> <input translate="" translate-attr-placeholder="cg-selector.search" autocomplete="off" class="cg-selector-input ng-pristine ng-untouched ng-valid ng-empty ng-valid-maxlength" type="text" ng-model="directiveScope.searchValue" ng-model-options="{ debounce: 500 }" ng-focus="openMenu()" ng-keydown="keydown($event)" maxlength="100" placeholder="Search"> <div ng-show="loading" class="progress-anim ng-hide"> <div class="ui-spinner"> <span class="side side-left"> <span class="fill"></span> </span> <span class="side side-right"> <span class="fill"></span> </span> </div> </div> <div class="search-icon"> <svg class="icon" cg-svg="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNS45MSIgaGVpZ2h0PSIxNiIgdmlld0JveD0iMCAwIDE1LjkxIDE2Ij48ZGVmcz48c3R5bGU+IC5fX1FDOGRsQ2lfX2Nscy0xIHsgZmlsbDogIzI1MmUzODsgZmlsbC1ydWxlOiBldmVub2RkOyB9IDwvc3R5bGU+PC9kZWZzPjxwYXRoIGlkPSJTZWFyY2hfMTYiIGNsYXNzPSJfX1FDOGRsQ2lfX2Nscy0xICIgZD0iTTExNjIuOTYsMTA1MWE2LDYsMCwxLDEsNS45Ny02QTUuOTkyLDUuOTkyLDAsMCwxLDExNjIuOTYsMTA1MVptMC0xMC4yOWE0LjI4NSw0LjI4NSwwLDEsMCw0LjI2LDQuMjlBNC4yODMsNC4yODMsMCwwLDAsMTE2Mi45NiwxMDQwLjcxWm04Ljk0LDE0LjI5YTEsMSwwLDAsMS0uNy0wLjI5bC00Ljk3LTVhMS4wMjcsMS4wMjcsMCwwLDEsMC0xLjQyLDEsMSwwLDAsMSwxLjQxLDBsNC45Nyw1QTEsMSwwLDAsMSwxMTcxLjksMTA1NVoiIHRyYW5zZm9ybT0idHJhbnNsYXRlKC0xMTU3IC0xMDM5KSI+PC9wYXRoPjwvc3ZnPg==" viewBox="0 0 15.91 16"><path id="Search_16" class="__QC8dlCi__cls-1 " d="M1162.96,1051a6,6,0,1,1,5.97-6A5.992,5.992,0,0,1,1162.96,1051Zm0-10.29a4.285,4.285,0,1,0,4.26,4.29A4.283,4.283,0,0,0,1162.96,1040.71Zm8.94,14.29a1,1,0,0,1-.7-0.29l-4.97-5a1.027,1.027,0,0,1,0-1.42,1,1,0,0,1,1.41,0l4.97,5A1,1,0,0,1,1171.9,1055Z" transform="translate(-1157 -1039)"></path></svg> </div> <!----> </div></cg-selector> </div></cg-navigation-search> <div class="right"> <cg-live-streams-button in-ide="false"><live-streams-button-react class="live-streams-button-react-container" in-ide="$ctrl.inIde" application="$ctrl.application"><a href="/live-streams" class="offContainer-0-2-2"><svg width="32px" height="26px" viewBox="0 0 32 26" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" class="offIcon-0-2-6"><g id="final" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="live-in-IDE" transform="translate(-1164.000000, -5.000000)" fill="currentColor" fill-rule="nonzero"><g id="live-(3)" transform="translate(1164.000000, 5.000000)"><path d="M15.0488021,8.38639154 C17.0931677,8.03292002 19.061816,9.15760213 19.4782609,10.892826 L19.4782609,10.892826 L30.873706,10.892826 C31.2522922,10.892826 31.5173026,11.1498962 31.5551612,11.4712339 L31.5551612,11.4712339 L31.5551612,24.8482854 C31.5551612,25.1696231 31.2522922,25.4266933 30.873706,25.4266933 L30.873706,25.4266933 L0.738243123,25.4266933 C0.359656906,25.4266933 0.0567879326,25.1696231 0.0567879326,24.8482854 L0.0567879326,24.8482854 L0.0567879326,11.4712339 C0.0946465543,11.1498962 0.359656906,10.892826 0.738243123,10.892826 L0.738243123,10.892826 L12.0958296,10.892826 C12.3986986,9.60747497 13.5723159,8.64346174 15.0488021,8.38639154 Z M7.4652402,16.4210526 L5.56521739,16.4210526 L5.56521739,23.2631579 L10.173374,23.2631579 L10.173374,21.7702498 L7.4652402,21.7702498 L7.4652402,16.4210526 Z M13.2086003,16.4210526 L11.2989571,16.4210526 L11.2989571,23.2631579 L13.2086003,23.2631579 L13.2086003,16.4210526 Z M16.1043312,16.4210526 L13.9686094,16.4210526 L16.2630673,23.2631579 L18.499803,23.2631579 L20.8038813,16.4210526 L18.6777799,16.4210526 L17.7013124,19.9076247 C17.6500038,20.0948232 17.5906782,20.3522212 17.5233356,20.6798186 C17.455993,21.0074159 17.411098,21.2804138 17.3886505,21.498812 C17.3713338,21.2264382 17.2812871,20.7645259 17.1185105,20.1130751 L17.0615579,19.8889049 L16.1043312,16.4210526 Z M25.7391304,16.4210526 L21.5638904,16.4210526 L21.5638904,23.2631579 L25.7391304,23.2631579 L25.7391304,21.75621 L23.4639133,21.75621 L23.4639133,20.4645403 L25.570774,20.4645403 L25.570774,18.9809922 L23.4639133,18.9809922 L23.4639133,17.9046008 L25.7391304,17.9046008 L25.7391304,16.4210526 Z M15.8059746,9.66272825 C14.6323573,9.66272825 13.3830228,10.5936269 13.3830228,12.0458289 C13.3830228,13.349087 14.4430642,14.4289295 15.8059746,14.4289295 C17.1310263,14.4289295 18.2289264,13.386323 18.2289264,12.0458289 C18.2289264,10.7425707 17.1688849,9.66272825 15.8059746,9.66272825 Z" id="Combined-Shape"></path><path d="M10.1271813,6.46043681 C9.86217096,6.72108844 9.86217096,7.13068385 10.1271813,7.39133548 C10.3921917,7.65198711 10.8086365,7.65198711 11.0736469,7.39133548 C13.6858917,4.82205514 17.9260574,4.82205514 20.5383023,7.39133548 C20.8033126,7.65198711 21.2197575,7.65198711 21.4847678,7.39133548 C21.7497782,7.13068385 21.7497782,6.72108844 21.4847678,6.46043681 C18.3425022,3.40708915 13.2694469,3.40708915 10.1271813,6.46043681 Z" id="Path"></path><path d="M8.12067436,4.48693161 C12.36084,0.279269603 19.2511091,0.279269603 23.4912748,4.48693161 C23.7562851,4.74758324 24.17273,4.74758324 24.4377403,4.48693161 C24.7027507,4.22627999 24.7027507,3.81668457 24.4377403,3.55603294 C19.667554,-1.13569638 11.9443951,-1.13569638 7.17420881,3.55603294 C6.90919846,3.81668457 6.90919846,4.22627999 7.17420881,4.48693161 C7.51493641,4.82205514 7.93138125,4.6358754 8.12067436,4.48693161 Z" id="Path"></path></g></g></g></svg></a></live-streams-button-react> </cg-live-streams-button> <div class="navigation-auth" ng-show="!navigationService.isLogged()"> <button ng-click="login()" class="navigation-auth_login-button" translate="navigation.connect.login">Log In</button> <button ng-click="signup()" class="navigation-auth_signup-button" translate="navigation.connect.signup">Sign Up</button> </div> <div class="navigation-notifications ng-hide" ng-show="navigationService.isLogged()"> <div class="navigation-notifications_nav-notifications-wrapper" ng-class="{
			'navigation-notifications_have-notifications': notificationsStatistics.getUnseenNotificationCount()
		}" ng-click="navigationService.toggleMenu('notifications')"> <div class="navigation-notifications_nav-notifications-icon"></div> <!----> </div> <!----> </div> <navigation-profile> <!----></navigation-profile> <div class="navigation-additional-links" ng-click="navigationService.toggleMenu('additionalLinks')"> <div class="cg-menu-actions theme-black" ng-click="toggleListActions()" ng-class="theme?'theme-black':''" theme="'black'" top-overlay="true" list-actions="additionalLinks"> <div class="menu-actions"> <div class="icon-actions white" ng-class="black ? 'black' : 'white'"></div> </div> <!----> </div> </div> </div> </div><!----> </div> </div><!----> </nav> <instant-messages><div id="instant-messages"> <!----> </div></instant-messages> <cg-codingamer-card-popup-display><div class="codingamer-card-popup" cg-codingamer-card="" card-data="service.popupConfig.cardData" style="display: none;"><div id="codingamer-card" ng-click="clickCard($event)"> <div class="header-container-card"> <div class="header-container-card-overlay"></div> <a class="cover-link cover" ng-href="/profile/" target="_blank" ng-style="cardData.cover?{'background-image': 'url(' + fileServletService.getFileUrl(cardData.cover, 'codingamercard_cover') + ')'}:null" href="/profile/"> </a> <a ng-href="/profile/" target="_blank" class="profil-pict" ng-style="cardData.avatar?{'background-image': 'url(' + fileServletService.getFileUrl(cardData.avatar, 'codingamercard_avatar') + ')'}:null" href="/profile/"> <!----> </a> <div class="pseudo-container"> <a class="pseudo-card" ng-bind="cardData.pseudo" ng-href="/profile/" target="_blank" href="/profile/"></a> <!----> </div> </div> <div class="info-container"> <!----> <!----> <!----> </div> <div class="unknown-size"> <!----> <!----> <p class="languages" ng-bind="getSkills()" title=""></p> </div> <div class="buttons"> <!----> <!----> <!----> </div> </div> <div ng-transclude=""></div> </div></cg-codingamer-card-popup-display> <div class="cg-confirm-popup"> <div class="cg-popup" close="defaultAction()" data-open="popupService.confirmPopup"> <!----> </div> </div> <cg-solution-overlay-content><div class="cg-popup" data-open="solution" close="onHide()"> <!----> </div></cg-solution-overlay-content> <div class="cg-level-popup"> <!----> </div> <div class="cg-arena-popup"> <!----> </div> <cg-info-map-tooltip-display><div class="info-map-tooltip" style="display: none;"> <!----> </div></cg-info-map-tooltip-display> <div class="cg-helper-tooltip" ng-click="$event.stopPropagation()"> <div class="overlay overlay-rect1"></div> <div class="overlay overlay-rect2"></div> <div class="overlay overlay-rect3"></div> <div class="overlay overlay-rect4"></div> <!----> </div> <cg-career-popup><div class="cg-career-popup"> <!----> </div></cg-career-popup> <div class="cg-generic-popup"> <div class="cg-popup" close="popupService.getLastGenericPopup().cancellable?reject():accept()" data-open="popupService.getLastGenericPopup()" no-overflow="popupService.getLastGenericPopup().noOverflow"> <!----> </div> </div> <cg-login-popup><div class="cg-login-popup"> <div class="cg-popup" close="$ctrl.defaultAction()" data-open="$ctrl.popupService.loginPopup" non-skippable="$ctrl.popupService.loginPopup.skipMode === 'mandatory'"> <!----> </div> </div></cg-login-popup> <div id="content" ng-class="pageLayoutService.pageClass" class="global-content"> <cg-cookies-banner origin="codingame"><!----> </cg-cookies-banner> <div class="cgPanel" ng-class="{'mobile-mode': mobileMode}" id="panelXP" data-visible="rankXpService.xpPanelOpen" close="rankXpService.closeXpPanel()" mobile-mode="pageLayoutService.mobile"> <!----> <!----> </div> <invite-panel><!----> </invite-panel> <div class="column-contents"> <div class="left-column"> <div id="scrollable-pane" cg-scroll-on-route-change=""> <!----><div ui-view="" class="contentView"><forum><div id="forum"> <div class="iframe_wrapper"> <iframe id="forumFrame" width="100%" height="100%" ng-src="https://forum.codingame.com/t/hitori-solver-some-thoughts/51095/3" seamless="seamless" src="https://forum.codingame.com/t/hitori-solver-some-thoughts/51095/3"> <p>Get a decent browser !</p> </iframe> </div> </div></forum></div> <footer id="footer" ng-show="pageLayoutService.showFooter" class="ng-hide"> <div class="logo"><span class="copyright" translate="footer.copyright" translate-values="{year: year}">© 2020 All rights reserved.</span></div> <div class="links"> <a target="_self" href="/blog" translate="footer.blog">BLOG</a> <a href="/about" translate="footer.about">ABOUT US</a> <a href="/legal/privacy-policy" translate="footer.legal">PRIVACY</a> <a href="/rules" translate="footer.rules">RULES</a> <a href="/faq" translate="footer.faq">FAQ</a> <a href="/careers/home" translate="footer.careers">CAREERS</a> <a href="/work/?cg_referrer=%24direct" target="_blank" translate="footer.companies" ng-click="trackClick('home')">COMPANIES</a> <a href="/work/offers/screening/?cg_referrer=%24direct" target="_blank" translate="footer.assessment" ng-click="trackClick('screening')">CODING TESTS</a> </div> <div class="buttons-group"> <div class="social-networks"> <a target="_blank" href="https://twitter.com/codingame" class="social-networks-button"> <svg class="social-networks-button-icon" cg-svg="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzMiIgaGVpZ2h0PSIzMiIgdmlld0JveD0iMCAwIDMyIDMyIj48ZGVmcz48c3R5bGU+IC5fXzJGX3JndmVfX2Nscy0xIHsgZmlsbDogIzdlODA4MjsgZmlsbC1ydWxlOiBldmVub2RkOyB9IDwvc3R5bGU+PC9kZWZzPjxwYXRoIGlkPSJUd2l0dGVyXzMyIiBjbGFzcz0iX18yRl9yZ3ZlX19jbHMtMSAiIGQ9Ik0xNjk0LjAxLDU3YTE2LDE2LDAsMSwxLTE2LDE2QTE2LDE2LDAsMCwxLDE2OTQuMDEsNTdabTEwLjI2LDEwLjI4NS0xLjkyLDEuOTU4czAuMzIsMTEuNTQ0LTExLjIxLDExLjc0OGMtNC43Ni4xNjMtNi4wOC0xLjk1OC02LjA4LTEuOTU4czMuNDgsMC44MTYsNS43Ni0xLjMwNWEzLjk5MiwzLjk5MiwwLDAsMS0zLjg0LTMuMjYzLDIuMTY0LDIuMTY0LDAsMCwwLDEuOTIuMzI2YzAtLjE0Mi0zLjM0LTAuNzE0LTMuMi00LjI0MmEyLjQsMi40LDAsMCwwLDEuOTIuNjUzcy0zLjM4LTIuMjg1LTEuMjgtNS41NDhjMy43Nyw0LjcxOCw3LjkxLDQuNSw4LjMsNC41NjVhMy43NiwzLjc2LDAsMCwxLS4zLTEuNDY1QTMuNzE4LDMuNzE4LDAsMCwxLDE2OTguMDIsNjVhMy42NDIsMy42NDIsMCwwLDEsMi45NywxLjU0OGMwLjI0LS4xNDguNC0wLjI0MywwLjQtMC4yNDNsMi41Ni0uOTc5LTEuOTIsMi4yODRaIiB0cmFuc2Zvcm09InRyYW5zbGF0ZSgtMTY3OCAtNTcpIj48L3BhdGg+PC9zdmc+" viewBox="0 0 32 32"><path id="Twitter_32" class="__2F_rgve__cls-1 " d="M1694.01,57a16,16,0,1,1-16,16A16,16,0,0,1,1694.01,57Zm10.26,10.285-1.92,1.958s0.32,11.544-11.21,11.748c-4.76.163-6.08-1.958-6.08-1.958s3.48,0.816,5.76-1.305a3.992,3.992,0,0,1-3.84-3.263,2.164,2.164,0,0,0,1.92.326c0-.142-3.34-0.714-3.2-4.242a2.4,2.4,0,0,0,1.92.653s-3.38-2.285-1.28-5.548c3.77,4.718,7.91,4.5,8.3,4.565a3.76,3.76,0,0,1-.3-1.465A3.718,3.718,0,0,1,1698.02,65a3.642,3.642,0,0,1,2.97,1.548c0.24-.148.4-0.243,0.4-0.243l2.56-.979-1.92,2.284Z" transform="translate(-1678 -57)"></path></svg> </a> <a target="_blank" href="https://www.facebook.com/CodinGame" class="social-networks-button"> <svg class="social-networks-button-icon" cg-svg="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzMiIgaGVpZ2h0PSIzMiIgdmlld0JveD0iMCAwIDMyIDMyIj48ZGVmcz48c3R5bGU+IC5fXzJqckxwSGJfX2Nscy0xIHsgZmlsbDogIzdlODA4MjsgZmlsbC1ydWxlOiBldmVub2RkOyB9IDwvc3R5bGU+PC9kZWZzPjxwYXRoIGlkPSJGYWNlYm9va18zMiIgY2xhc3M9Il9fMmpyTHBIYl9fY2xzLTEgIiBkPSJNMTUzOCw1N2ExNiwxNiwwLDEsMS0xNiwxNkExNi4wMDcsMTYuMDA3LDAsMCwxLDE1MzgsNTdabTIsMTJ2MWg0bC0xLDNoLTN2OWgtNFY3M2gtMlY3MGgyVjY3YTIuOTIzLDIuOTIzLDAsMCwxLDMtM2g0djRoLTJBMS4xNTcsMS4xNTcsMCwwLDAsMTU0MCw2OVoiIHRyYW5zZm9ybT0idHJhbnNsYXRlKC0xNTIyIC01NykiPjwvcGF0aD48L3N2Zz4=" viewBox="0 0 32 32"><path id="Facebook_32" class="__2jrLpHb__cls-1 " d="M1538,57a16,16,0,1,1-16,16A16.007,16.007,0,0,1,1538,57Zm2,12v1h4l-1,3h-3v9h-4V73h-2V70h2V67a2.923,2.923,0,0,1,3-3h4v4h-2A1.157,1.157,0,0,0,1540,69Z" transform="translate(-1522 -57)"></path></svg> </a> <a target="_blank" href="https://fr.linkedin.com/company/codingame" class="social-networks-button"> <svg class="social-networks-button-icon" cg-svg="data:image/svg+xml;base64,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" viewBox="0 0 32 32"><path id="LinkedIn_32" class="__l8RUw5o__cls-1 " d="M1745,57a16,16,0,1,1-16,16A16,16,0,0,1,1745,57Zm-4,23h-3.5a1.177,1.177,0,0,1-.5-1V70a1.769,1.769,0,0,1,1-1h3c0.87,0,1,.161,1,1v9C1742,80,1742,80,1741,80Zm-1.5-12.031a2.5,2.5,0,1,1,2.5-2.5A2.5,2.5,0,0,1,1739.5,67.969ZM1753.48,80h-3.15c-0.29,0-.33-0.317-0.33-1V74a1.81,1.81,0,0,0-1.47-1.5A1.671,1.671,0,0,0,1747,74v5c0,0.714-.04,1-0.33,1h-3.15a0.508,0.508,0,0,1-.52-0.5v-10a0.508,0.508,0,0,1,.52-0.5h3.15a0.508,0.508,0,0,1,.52.5v0.081a4.394,4.394,0,0,1,2.38-.581c3.89,0,4.43,2.405,4.43,5v5.5A0.508,0.508,0,0,1,1753.48,80Z" transform="translate(-1729 -57)"></path></svg> </a> <a target="_blank" href="https://www.youtube.com/channel/UCJ6woCHjGCBXqpf91SsAcoQ" class="social-networks-button"> <svg class="social-networks-button-icon" cg-svg="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzMiIgaGVpZ2h0PSIzMiIgdmlld0JveD0iMCAwIDMyIDMyIj48ZGVmcz48c3R5bGU+IC5fXzJTcTZoVkxfX2Nscy0xIHsgZmlsbDogIzdlODA4MjsgZmlsbC1ydWxlOiBldmVub2RkOyB9IDwvc3R5bGU+PC9kZWZzPjxwYXRoIGlkPSJZb3V0dWJlXzMyIiBjbGFzcz0iX18yU3E2aFZMX19jbHMtMSAiIGQ9Ik0xNjQzLDU3YTE2LDE2LDAsMSwxLTE2LDE2QTE2LDE2LDAsMCwxLDE2NDMsNTdabTUuMTUsMjIuMDA5aC0xMC4zMWMtMi4xMywwLTMuODUtLjYyOS0zLjg1LTMuODI1VjcwLjgzYzAtMy4zODcsMS43Mi0zLjgyNCwzLjg1LTMuODI0aDEwLjMxYzIuMTIsMCwzLjg1LjA1NSwzLjg1LDMuODI0djQuMzU0QzE2NTIsNzguNjI2LDE2NTAuMjcsNzkuMDA5LDE2NDguMTUsNzkuMDA5Wm0tNy4xNi05LjAyMlY3Nmw2LjAyLTMuNTA4WiIgdHJhbnNmb3JtPSJ0cmFuc2xhdGUoLTE2MjcgLTU3KSI+PC9wYXRoPjwvc3ZnPg==" viewBox="0 0 32 32"><path id="Youtube_32" class="__2Sq6hVL__cls-1 " d="M1643,57a16,16,0,1,1-16,16A16,16,0,0,1,1643,57Zm5.15,22.009h-10.31c-2.13,0-3.85-.629-3.85-3.825V70.83c0-3.387,1.72-3.824,3.85-3.824h10.31c2.12,0,3.85.055,3.85,3.824v4.354C1652,78.626,1650.27,79.009,1648.15,79.009Zm-7.16-9.022V76l6.02-3.508Z" transform="translate(-1627 -57)"></path></svg> </a> </div> <div class="langchooser"> <button class="langmenu-item-button" ng-click="langMenuVisible = !langMenuVisible"> <span class="langmenu-item"> <span class="flag footer-usa_uk" ng-class="langs[getCurrentLanguage()].flag"></span> <span class="label" ng-bind="langs[getCurrentLanguage()].name">EN</span> </span> </button> <!----> </div> </div> </footer> </div> </div> <!----><div ng-if="pageLayoutService.chatVisible" class="chat-wrapper"> <div id="chat"> <div class="chat theme-black" ng-class="{'small-chat' : !chatBigLayout, 'theme-black': theme === 'black' || !theme || theme === 'auto'}" ng-click="toggleIfSmall()"> <!----> <!----><cg-discord-disclaimer ng-if="chatBigLayout" theme="theme"><div class="cg-discord-disclaimer_container" ng-class="{'theme-white': $ctrl.theme === 'white'}"> <!----> <!----><div class="cg-discord-disclaimer_big" ng-if="!$ctrl.minifyDicordDisclaimer"> <div class="cg-discord-disclaimer_banner-container"> <img class="cg-discord-disclaimer_banner-icons" ng-src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzOS43OCIgaGVpZ2h0PSIzOS43ODEiIHZpZXdCb3g9IjAgMCAzOS43OCAzOS43ODEiPjxkZWZzPjxzdHlsZT4gLl9fMVJ0WmlMU19fY2xzLTEgeyBmaWxsOiAjZjJiYjEzOyBmaWxsLXJ1bGU6IGV2ZW5vZGQ7IH0gPC9zdHlsZT48L2RlZnM+PHBhdGggaWQ9ImNvZGluIiBjbGFzcz0iX18xUnRaaUxTX19jbHMtMSAiIGQ9Ik0xNzM4LjMyLDEwMy4zOTNsLTAuMTMsMGEyLjg2OSwyLjg2OSwwLDAsMS0yLjc4LTIuOTMyLDIuODEsMi44MSwwLDAsMSwyLjg1LTIuNjg3bDAuMTMsMGEyLjg2OSwyLjg2OSwwLDAsMSwyLjc4LDIuOTMyLDIuODEsMi44MSwwLDAsMS0yLjg1LDIuNjg4bS05LjQ4LTEzLjMxNWExOS45MDUsMTkuOTA1LDAsMCwwLTE3LjY4LDI5LjA0MWM0LjY1LS43LDEyLjU2LTIuODQsMTMuMTEtOS4zYTYuMzM0LDYuMzM0LDAsMCwxLDYuNDMtNi4xYzIuMTMsMCwzLjk3LDEuMTUsMy45OSwzLjU2OSwwLjE4LDUuMi00LjI0LDUuMDMtOS4yNyw3LjYyMy01LjgyLDMuNzE0LTYuMjYsNy41NzYtNS41NSwxMS42NGEzLjYyNiwzLjYyNiwwLDAsMCwuNTIsMS40NDUsMTkuOSwxOS45LDAsMSwwLDguNDUtMzcuOTE2IiB0cmFuc2Zvcm09InRyYW5zbGF0ZSgtMTcwOC45NCAtOTAuMDk0KSI+PC9wYXRoPjwvc3ZnPg==" alt="codingame" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzOS43OCIgaGVpZ2h0PSIzOS43ODEiIHZpZXdCb3g9IjAgMCAzOS43OCAzOS43ODEiPjxkZWZzPjxzdHlsZT4gLl9fMVJ0WmlMU19fY2xzLTEgeyBmaWxsOiAjZjJiYjEzOyBmaWxsLXJ1bGU6IGV2ZW5vZGQ7IH0gPC9zdHlsZT48L2RlZnM+PHBhdGggaWQ9ImNvZGluIiBjbGFzcz0iX18xUnRaaUxTX19jbHMtMSAiIGQ9Ik0xNzM4LjMyLDEwMy4zOTNsLTAuMTMsMGEyLjg2OSwyLjg2OSwwLDAsMS0yLjc4LTIuOTMyLDIuODEsMi44MSwwLDAsMSwyLjg1LTIuNjg3bDAuMTMsMGEyLjg2OSwyLjg2OSwwLDAsMSwyLjc4LDIuOTMyLDIuODEsMi44MSwwLDAsMS0yLjg1LDIuNjg4bS05LjQ4LTEzLjMxNWExOS45MDUsMTkuOTA1LDAsMCwwLTE3LjY4LDI5LjA0MWM0LjY1LS43LDEyLjU2LTIuODQsMTMuMTEtOS4zYTYuMzM0LDYuMzM0LDAsMCwxLDYuNDMtNi4xYzIuMTMsMCwzLjk3LDEuMTUsMy45OSwzLjU2OSwwLjE4LDUuMi00LjI0LDUuMDMtOS4yNyw3LjYyMy01LjgyLDMuNzE0LTYuMjYsNy41NzYtNS41NSwxMS42NGEzLjYyNiwzLjYyNiwwLDAsMCwuNTIsMS40NDUsMTkuOSwxOS45LDAsMSwwLDguNDUtMzcuOTE2IiB0cmFuc2Zvcm09InRyYW5zbGF0ZSgtMTcwOC45NCAtOTAuMDk0KSI+PC9wYXRoPjwvc3ZnPg=="> <img class="cg-discord-disclaimer_banner-icons cross-icon" ng-src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMiIgaGVpZ2h0PSIxMiIgdmlld0JveD0iMCAwIDEyIDEyIj48ZGVmcz48c3R5bGU+IC5fX2YzTDRCRnhfX2Nscy0xIHsgZmlsbDogI2ZmZjsgZmlsbC1ydWxlOiBldmVub2RkOyB9IDwvc3R5bGU+PC9kZWZzPjxwYXRoIGlkPSJ4IiBjbGFzcz0iX19mM0w0QkZ4X19jbHMtMSAiIGQ9Ik0xNzcxLjQxLDExMGw0LjMsNC4yOTNhMSwxLDAsMCwxLTEuNDIsMS40MTRsLTQuMjktNC4yOTMtNC4yOSw0LjI5M2ExLDEsMCwwLDEtMS40Mi0xLjQxNGw0LjMtNC4yOTMtNC4zLTQuMjkzYTEsMSwwLDAsMSwxLjQyLTEuNDE0bDQuMjksNC4yOTMsNC4yOS00LjI5M2ExLDEsMCwwLDEsMS40MiwxLjQxNFoiIHRyYW5zZm9ybT0idHJhbnNsYXRlKC0xNzY0IC0xMDQpIj48L3BhdGg+PC9zdmc+" alt="x" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMiIgaGVpZ2h0PSIxMiIgdmlld0JveD0iMCAwIDEyIDEyIj48ZGVmcz48c3R5bGU+IC5fX2YzTDRCRnhfX2Nscy0xIHsgZmlsbDogI2ZmZjsgZmlsbC1ydWxlOiBldmVub2RkOyB9IDwvc3R5bGU+PC9kZWZzPjxwYXRoIGlkPSJ4IiBjbGFzcz0iX19mM0w0QkZ4X19jbHMtMSAiIGQ9Ik0xNzcxLjQxLDExMGw0LjMsNC4yOTNhMSwxLDAsMCwxLTEuNDIsMS40MTRsLTQuMjktNC4yOTMtNC4yOSw0LjI5M2ExLDEsMCwwLDEtMS40Mi0xLjQxNGw0LjMtNC4yOTMtNC4zLTQuMjkzYTEsMSwwLDAsMSwxLjQyLTEuNDE0bDQuMjksNC4yOTMsNC4yOS00LjI5M2ExLDEsMCwwLDEsMS40MiwxLjQxNFoiIHRyYW5zZm9ybT0idHJhbnNsYXRlKC0xNzY0IC0xMDQpIj48L3BhdGg+PC9zdmc+"> <img class="cg-discord-disclaimer_banner-icons" ng-src="data:image/svg+xml;base64,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" alt="discord" src="data:image/svg+xml;base64,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"> </div> <div class="cg-discord-disclaimer_big-text" translate="cg-discord-disclaimer.incentiveText">Join the CodinGame community on Discord to chat about puzzle contributions, challenges, streams, blog articles - all that good stuff!</div> <a href="https://discord.gg/qAKXEEv" target="_blank" rel="noopener" class="cg-discord-disclaimer_big-join-button" translate="cg-discord-disclaimer.joinUs">JOIN US ON DISCORD</a> </div><!----> <button class="cg-discord-disclaimer_toggle" ng-class="{'theme-white': $ctrl.theme === 'white','minified': $ctrl.minifyDicordDisclaimer}" ng-click="$ctrl.minifyDiscordDisclaimerToggle()"> <img class="cg-discord-disclaimer_toggle-arrow" ng-src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMCIgaGVpZ2h0PSI2IiB2aWV3Qm94PSIwIDAgMTAgNiI+PGRlZnM+PHN0eWxlPiAuX19YYUtWTUpsX19jbHMtMSB7IGZpbGw6ICM4Mzg4OTE7IGZpbGwtcnVsZTogZXZlbm9kZDsgfSA8L3N0eWxlPjwvZGVmcz48cGF0aCBpZD0iYXJyb3ciIGNsYXNzPSJfX1hhS1ZNSmxfX2Nscy0xICIgZD0iTTE4OTMsMTAyYTEuMDA2LDEuMDA2LDAsMCwwLS43MS4yOTNsLTQsNGExLDEsMCwwLDAsMS40MiwxLjQxNGwzLjI5LTMuMjkzLDMuMjksMy4yOTNhMSwxLDAsMCwwLDEuNDItMS40MTRsLTQtNEExLjAwNiwxLjAwNiwwLDAsMCwxODkzLDEwMloiIHRyYW5zZm9ybT0idHJhbnNsYXRlKC0xODg4IC0xMDIpIj48L3BhdGg+PC9zdmc+" alt="toggle" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMCIgaGVpZ2h0PSI2IiB2aWV3Qm94PSIwIDAgMTAgNiI+PGRlZnM+PHN0eWxlPiAuX19YYUtWTUpsX19jbHMtMSB7IGZpbGw6ICM4Mzg4OTE7IGZpbGwtcnVsZTogZXZlbm9kZDsgfSA8L3N0eWxlPjwvZGVmcz48cGF0aCBpZD0iYXJyb3ciIGNsYXNzPSJfX1hhS1ZNSmxfX2Nscy0xICIgZD0iTTE4OTMsMTAyYTEuMDA2LDEuMDA2LDAsMCwwLS43MS4yOTNsLTQsNGExLDEsMCwwLDAsMS40MiwxLjQxNGwzLjI5LTMuMjkzLDMuMjksMy4yOTNhMSwxLDAsMCwwLDEuNDItMS40MTRsLTQtNEExLjAwNiwxLjAwNiwwLDAsMCwxODkzLDEwMloiIHRyYW5zZm9ybT0idHJhbnNsYXRlKC0xODg4IC0xMDIpIj48L3BhdGg+PC9zdmc+"> </button> </div></cg-discord-disclaimer><!----> <!----><cg-chat-navbar ng-if="chatBigLayout" theme="theme" current-room="currentRoom" switch-room="switchRoomFromPanel(currentTabRoom)" rooms="roomsArray" max-visible-tabs="MAX_TABS_SHOWN"><div class="cg-chat-navbar" ng-class="{'theme-white': $ctrl.theme === 'white'}"> <!----> <!----> <!----> <!----> </div></cg-chat-navbar><!----> <!----> <!----><div class="big" ng-if="chatBigLayout"> <div class="messages-wrap"> <div id="messages" class="messages" chat-autoscroll=""> <div class="room-intro"> <!----> <!----> <!----> </div> <!----> </div> </div> <div class="footer"> <div class="chat-state"><!----></div> <div class="send-form"> <form class="ng-pristine ng-valid ng-valid-maxlength"> <div class="cg-inputcontainer"><textarea ng-click="clickInput($event)" id="chat-input" class="chat-input cg-field ng-pristine ng-untouched ng-valid ng-empty ng-valid-maxlength" ng-model="messageWrapper.chatMessage" ng-keydown="chatKeydown($event)" ng-trim="false" ng-change="inputChange()" ng-maxlength="10000" maxlength="10000"></textarea><div class="cg-inputoverlay"><!----></div><!----></div> </form> <span class="emojis-btn chat-chat_smiley" ng-click="toggleEmojis($event)" translate-attr-title="chat.titles.emojis" translate="" title="Emojis"></span> </div> <div class="settings-bar"> <span class="button-wrapper hide-wrapper" ng-click="toggleChat($event)" translate-attr-title="chat.titles.hide" translate="" title="Hide"> <span class="hide-btn chat-chat_hide"></span> </span> <span class="button-wrapper" ng-click="toggleSettings($event)" translate-attr-title="chat.titles.settings" translate="" title="Settings"> <span class="settings-btn chat-chat_settings"></span> </span> <!----><span ng-if="!chatService.credentials.guest" class="button-wrapper" ng-click="openPeople()" translate-attr-title="chat.titles.people" translate="" title="Participants"> <span ng-show="currentRoom.type === 'groupchat'" class="occupants-btn chat-chat_people ng-hide"></span> </span><!----> <button type="button" class="help-center cg-help-button" ng-click="launchHelp($event)" article-id="chatService.helpCenterId" title="Help"></button> </div> <!----> <!----> </div> </div><!----> <!----><div ng-if="!chatService.credentials.guest" class="chat-people" ng-class="{ 'chat-people-visible' : peopleVisible}"> <div class="people-header" ng-click="closePeople()"> <span class="people-close"> <span class="chat-button_close_black"></span> </span> <span translate="chat.occupants" class="people-title">Online Participants</span> </div> <div class="people" vs-repeat=""> <!----> </div> </div><!----> </div> </div> </div><!----> </div> </div>   <div class="cfp-hotkeys-container fade" ng-class="{in: helpVisible}" style="display: none;"><div class="cfp-hotkeys"><!----><h4 class="cfp-hotkeys-title" ng-if="!header">Keyboard Shortcuts:</h4><!----><!----><table><tbody><!----><tr ng-repeat="hotkey in hotkeys | filter:{ description: '!$$undefined$$' }"><td class="cfp-hotkeys-keys"><!----><span ng-repeat="key in hotkey.format() track by $index" class="cfp-hotkeys-key">?</span><!----></td><td class="cfp-hotkeys-text">Show / hide this help menu</td></tr><!----></tbody></table><!----><div class="cfp-hotkeys-close" ng-click="toggleCheatSheet()">×</div></div></div></body></html>